
Mathcad Tutorial
 by Prof. Bern Kohler, The Ohio State University

modified by Prof. D.S. Hamilton, University of Connecticut

The goal of this tutorial is to help you to perform basic tasks using Mathcad as quickly as possible.  The
text below describes some of the most commonly used features of the program--the ones you are most
likely to use in your work for Physics 258 and beyond.  While you can learn a great deal about Mathcad just
by reading the contents of this file, you will find that nothing beats working with the program yourself. This
tutorial is a "live" Mathcad worksheet that encourages you to interact with the Mathcad program, so don't
just print the contents of this file.  Instead, you should read through this worksheet, taking time to try the
tasks printed in bold text.  Don't be afraid to experiment! 

Mathcad can do much more than is described in this simple tutorial.  To learn more, consult the program's
help files (help menu) or copies of the printed manual (available in the 258 lab).  In particular, try the
"Resource Center", which is accessible from the Help menu.

_____________________________________________________________ 

Mathcad creates worksheets that consist of text regions and math regions.  

My Lab Report The text on the left is a "text region".  This comment is
also a text region.

3 4+ 7= The simple equation on the left is a "math region"

______________________________________________________________ 

Text regions
The text you are now reading is part of a text region.  With time it should be easy for you to distinguish
math regions from text regions.  Text regions are most often used to add comments to worksheets, making
it simpler to follow the calculations.  You select a text region by left-clicking it with the mouse.  Once a
text region is selected, a box with square handles will appear.  Moving the mouse over one of these
handles changes the cursor to an arrow, indicating that you can resize the box.  Moving the mouse to any
edge of the box around a text region will change the cursor to a hand, indicating that you can click and
drag the text box to a new location.

Use the mouse to select the text region above and resize it so it is no wider than the
horizontal line above "Text regions".

↓   The dashed, horizontal line below indicates a page break.  ↓ NOTE: Page breaks only affect
printing
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To create a text region, click the mouse on a blank part of a worksheet.  Select "Text Region" from the
Insert menu --or-- simply type the double quote character (") on the keyboard and then begin typing the
text you want to enter.

The text in a text region can be edited much like the text in a word processor.  Note the vertical red cursor in

a selected region which indicates where text you type will be inserted. You can change the font, font size,
font color and style using buttons on the toolbars or by selecting commands in the Format menu.

Remove the bold formatting from the text in this sentence.

The solid, vertical line at right    →  
indicates the right margin.  The width of the
margins can be adjusted using "Page Setup"
in the File menu.   

You can also enter Greek letter either by using the "Greek" pallet (View-Toolbars-Greek) or if you place the
insertion point directly to the right of the letter you want to turn into a Greek letter and then type <ctrl>G,
the letter turnes into its Greek equivalant.  The keysequence <ctrl>G toggles between Greek and roman
letters. (If you place the insertion point directly to the right of a Greek letter and press <ctrl>G, the Greek
letter will turn back into an equivalent roman letter.)  Thus a p turns into a π , a d turns into a δ, and a D
becomes a ∆.  

Type in below the fist three letters of the Greek alphabet (alpha, beta, and gamma)

There is a text region "hidden" off the right edge of the paper.  Scroll the window
horizontally so you can find it, then move it between the horizontal lines below:

__________________________________

__________________________________
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You will next enter a simple math expression.  Click anywhere in the white space below this line,
then follow the instructions in the next paragraph.

Another way to enter mathematical expressions is to use the "Calculator palette".  Bring up this palette by
clicking on the blue calculator icon on the "Math" toolbar.

Replace 4 everywhere in the above expressions by 2, and observe how the results change. 

To see this, change the "4" in the first expression above to a "2" by clicking and editing.  Mathcad
automatically recomputes the new result when you hit "enter" or click the mouse anywhere else on the page.
Note that editing mathematical expressions is a bit different than editing text, and requires some getting used
to.  See the on-line help (Help menu) for more information about editing math regions.

The math regions in a Mathcad document are "live", meaning that they are recomputed as information for
any calculation is changed.

Type:  cos(p<cntrl>G/4)^2=cos
π
4







2

0.5=

Type:  exp(2)/4<space>+1=
exp 2( )

4
1+ 2.847=

Type:  \25<space>/(4+1)=25

4 1+( )
1=

Type: 2.3^4=2.3
4

27.984=

Type: 2*(3+4)=2 3 4+( )⋅ 14=

The following math regions are examples of simple formulas evaluated by Mathcad.

Mathcad is a WYSIWYG (what-you-see-is-what-you-get) word processor for mathematics.

Of course, the most powerful features of Mathcad have to do with math regions.  The rest of this tutorial
will concentrate on these features.

Math regions
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Instructions.  Numbers can be entered by clicking on the appropriate buttons on the
arithmetic palette (blue calculator icon on tool bar), but it's simplest to use the keyboard to
enter them directly.  Type 2.  The red cross cursor disappears, and a box is displayed
containing the number 2.  A blue line is visible immediately to the right of the 2.  This line is
the insertion line for math expressions.  Note also that the 2 is underlined by a blue line.  A
useful rule to remember is that the underlined expression to the left of the insertion line is
used as the operand of the next operator you type.  An operator can be something like '+', or
'-', or exponentiation.  Now type '+' (or click on the plus sign in the arithmetic palette),
followed by a '3'.  Now click on the multiplication symbol in the palette (or type an asterisk '*').
Type '5', then press the equals button on the palette or type "=".

If you followed the above instrutions, your result should look like this:

2 3 5⋅+ 17=

In the space below type the following sequence of keys:  2+3<space>*5=
[NOTE:  <space> means to type the space bar once.

Typing a space "extends the selection", underlining all of 2+3.  Thus, 2+3 became the operand for the
next operator (multiplication) that you typed.  Note how Mathcad automatically added parentheses to
indicate that the result of 2+3 is to be multiplied by 5.  Using the space bar in this way is a very useful
skill that requires a little practice.

Variables
Mathcad can compute with variables that you define and modify.  Recall above how you changed all
occurrences of "4" to "2" in the three expressions.  Whenever you frequently modify input values it may be
more convenient to use variables.  Like this:

a 2:= This line defines the value of variable "a".

This line and the following two math regions perform computations
using the variable "a".2 3 a+( ) 10=

25

4 a+( )
0.833=

cos
π
a







2
0=
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γ 1.033=

γ
1

1
v
2

c
2

−

:=
The Lorentz factor "gamma"  (entered the γ from the GREEK toolbar)

v .25 c⋅:=

Type "3*10^8" to enter the numerical value for the speed of light. c 3 108⋅:=

Consider a relativistic electron moving with a velocity of 0.25 c in a magnetic field of 1T.  What is the
radius of curvature of its circular path?:

Here is a calculation that should start to give you a feeling for the power of a "math word processor" like
Mathcad:

New result! var myvar_1+ 27=

Now change the value of varvar 17:=

Display the value of "var".var 4=

Mathcad displays the result of adding the two variables.var myvar_1+ 14=

A second variable assignmentvar 4:=

Assignment statement.  Note that variable names can use a variety of
characters.  See program help for exact naming rules. 

myvar_1 10:=

Now move the line that defines "a" below this paragraph.  Note how the calculations above "break".
The results disappear and "a" becomes highlighted in red text.  Selecting any of the broken expressions
(left-click of mouse) reveals the trouble.  An error message is displayed indicating that "This variable or
function is not defined above".  This is because the ordering of math regions on the page (worksheet) is
significant.  Mathcad evaluates in "reading order", from left to right and then top to bottom.  Thus, variable
assignments must occur to the left of or above statements that use the variable name.  This is a very
important point.  Many problems with broken worksheets can be fixed by carefully paying attention to where
variable definitions are placed.

The  following example should make this more clear:

Try redefining the value of "a" above, and watch how the calculated results change.

How to type ":=".  (1) Type a colon (":") or (2) Click on the button with the ":=" symbol on the
Calculator or Evaluation palette. 

The first line above tells Mathcad that the value of variable "a" is 2.  This is how you create
variables in Mathcad.  Just type the name and assign a value to it.  Notice the funny
equals sign which looks like ":=".  This is how Mathcad denotes the assignment operator.
The assignment operator assigns a value to a variable.  It is different from the simple
equals sign "=" which asks Mathcad to evaluate the expression to the left of "=" and
display the result.  Just remember, use ":=" when you are defining variables (or changing
their values), and use "=" when you want Mathcad to display a result.  There are four
different equals signs on the "Evaluation" pallet.
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array2

10

20

30











=
Display the results.  This was done by typing   array2=

Multiply the elements in array1 by two, and store the results in a new
array.

array2 2 array1⋅:=

With Mathcad you can easily perform math on vectors. 

array1

5

10

15











:=

Select "Matrix..." from the Insert menu.  An array (or vector) with n elements is just a matrix with n rows
and 1 column.  Fill in the values you need in the dialog box and click OK.  Try creating an array named
array1 with 3 elements (3 rows, 1 column).  Enter the values 5, 10, and 15 in the placeholder boxes.  You
can move between the placeholders using the "Tab" key.  The correct result is shown below.

How to create an array (vector) variable

For many experiments it is simplest to work with data in arrays.  This is often the case when multiple
measurements or readings are recorded in an experiment.  Mathcad has a variety of tools for working with
arrays and matrices.

Working with arrays

Note about displaying very small numbers.  Mathcad displays very small numbers as "0" when they are less
than a "zero tolerance".  Any number greater than or equal to 10-Z will be displayed, where Z is the zero
tolerance (set using the Tolerance Tab accessed from the Format->Result menu).  Otherwise, the number
will be displayed as zero. You should change the zero tolerance to an appropriate value, if you wish to view
the magnitude of a very small number.

"radius" refers to a different (undefined) variableradius =radius

Finally,note that variable names are case-sensitive.  Thus, 

Radius 4.405 10 4−×=

Radius
m γ⋅ v⋅
e B⋅

:=
Mathcad calculates the radius (in meters).  By changing the values of
"B" or "v"  above, you can perform additional calculations easily.

magnetic fieldB 1:=

electron charge and massm 9.11 10 31−⋅:=e 1.602 10 19−⋅:=
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Assign the second column of the matrix "data" to the vector y.y data 1〈 〉
:=

To get the result on the left type   x:data<ctrl-6>0

NOTE:  <ctrl-6> means to hold the control key and press 6 at the same time.
Alternatively, you can select matrix column from the "Vector and Matrix
Palette".

x data 0〈 〉
:=

This will frequently be useful for dealing with x,y datafiles.  You will frequently want to manipulate the
columns separately.  Assuming the first column represents the x values, and the second column contains y
values, then we might do the following:

Contents of a two column data file were cut to the clipboard and
then pasted to create this two column matrix.

data

1

2

3

4

2

5

10

17











:=

  Provided the columns are separated by tabs, then you can use this method to create matrices.

This vector was created by pasting data from the clipboard.x

3

5.2

15

17.9











:=

The simplest method is to use the clipboard.  Open the data file using a simple Windows utility program like
"notepad" or "wordpad".  Cut the data to the clipboard, then type your array name, type the assignment
operator, then paste the data from the clipboard (Edit menu, or control-v).  This creates a new vector using
the data you cut from the file.  This cut/paste method can also be used to create arrays or matrices from
columns in Excel worksheets.

Reading data from a file into an array

array217 =17

To enter the above expression you type:  array2[0=
The left bracket "[" is used to enter an array subscript.
Try to display the other elements of array2.
What happens when you try to display element 17 of array2?  Click below to
read the error message.

The first element of array2 is equal to 10.  Note that the index of the first
element is 0 and not 1.  This is because arrays in Mathcad are
numbered 0,1,2....  Such arrays are called "zero-based".

array20 10=

You can also refer to individual elements of an array.  This is done by subscripting.   
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Try displaying the values of the vectors x and y to make sure you understand what is going on.

An alternative method for reading in data from a file is to use the Mathcad function "READPRN".  An example
is shown below.  Note the full path name is given of the data file to read.

You will see an error message if Mathcad
can't find the given filename.my_matrix READPRN "c:\temp\myfile.dat"( ):= "c:\temp\myfile.dat"

While this method is slightly more complicated, it has the advantage that you don't have to cut/paste each
time the data in the file changes.

Create a simple two column data file in a directory on your computer.  Modify the pathname
above to point to the file, push F9 to recalculate the worksheet (this insures that Mathcad reads the
file), then display the values of my_matrix.

Making Graphs

A frequent task in Physics 258 is making graphs to display your results.  While Mathcad can generate a
large number of 2D and 3D graphs, the only one you need to learn is the "X-Y Plot".  Select graph->X-Y plot
from the Insert menu, or simply click on empty space and type the "@" character.  When you do you will see
an empty template like the one below.  Try it.

The placeholder on the bottom, horizontal axis is used to specify a vector of x values to plot.  The
placeholder on the left axisis used to specify an equal length vector of y values.  An example should make
this clearer.  First let's define 
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xvals

1

2

3

4











:= First we create some x values.

We can use this expression to generate an equal length array of y values.
Now we have a set of (x,y) pairs, suitable for graphing. yvals 2 xvals⋅ 1+:=

yvals

3

5

7

9











= Display the resulting vector

Now generate the graph....  We type "@" in whitespace below and then fill in the placeholders with our
two arrays:

1 2 3 4

4

6

8

10

yvals

xvals

Voila.  Mathcad graphs the result--a simple
straight line.

1 2 3 4

4

6

8

10
My Graph

X values 

Y
 v

al
ue

s

Try double-clicking the graph above to bring
up menus that allow you to change the trace
appearance, add a title, label the axes etc.
Can you make the graph above look like the
one at right?  HINT:  Check "hide arguments"
to hide the names of the mathcad variables
and show only the axis labels.

Finally note that graphs can be resized much like text regions.  Try increasing the size of these graphs.
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exp 1 2i+( ) 1.131− 2.472i+=

acos 17( ) 3.525i=

(3) Mathcad can use complex numbers without a change in notation

Why not V 1.492 103× in3=

And we can ask for the volume in liters!V 24.453 L=

V 0.024 m3=
Mathcad handles all the unit conversions and displays the result in
cubic meters!

Solve for volume occupied by 1 mol of an ideal gasV
n R⋅ T⋅

P
:=

R 8.31441 J⋅ K 1−⋅ mol 1−⋅:=

P 1 atm⋅:=

n 1 mol⋅:=

T 298 K⋅:=

see "units of measurement" in the help index(2) Mathcad can compute with units  

f sqr 10( )( ) 3.679=f 50( ) 6.065=f t( ) 10 exp
t−

100






⋅:=

sqr 10( ) 100=sqr 2( ) 4=sqr x( ) x2:=

see "functions, user-defined" in the help index(1) You can define your own functions:

A.1  Other features
Mathcad can do much more than can be described in this short tutorial.  Consult the help files for
more information.  To whet your appetite, here are a few examples of some of these features with
pointers to relevant documentation.

Appendix

That completes the tutorial.  Hopefully you found this a useful way to quickly learn some of the
basic features of Mathcad. 

To learn about some more advanced features, see the appendix below.
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1

N

i

i2∑
=

1

3
N 1+( )3⋅

1

2
N 1+( )2⋅−

1

6
N⋅+

1

6
+→

xx
2

2 x⋅+ 1+( )⌠

⌡

d
1

3
x
3

⋅ x
2

+ x+→ z
exp z3( )d

d
3 z2 exp z3( )⋅⋅→

see "symbolic calculation" in the help index (4) Mathcad can do some symbolic math

Y

2

3

6

11

18

















=

Range variables are frequently used for creating new vectors.
See the result at right -->

Yi i i⋅ 2+:=

Display the result.sum 33=

Range variables can be used in iterative calculations such as sums.sum

i

Xi∑:=

Xi

3
4
5

10
11

:= Type:  X[i:3,4,5,10,11

Display the result using i=i

0

1

2

3

4

=

Expression on left was entered by typing:  i:0;4i 0 4..:=

see "range variables" in the help index(4) Mathcad can use range variables
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Other useful techniques:

A.   Fast way to export x,y data

i 0 19..:=

xi 2 5
i

20
⋅+:=

yi xi( )2
:=

Copy the columns to a matrix like this:

mati 0, xi:= mati 1, yi:=

Type name of matrix followed by equals sign to
display it. Then click box at upper left, right click
anywhere in table and choose copy. The data can
now be pasted to another program!

mat

0 1
0

1

2

3

4

5

6

7

2 4

2.25 5.063

2.5 6.25

2.75 7.563

3 9

3.25 10.563

3.5 12.25

3.75 14.063

=

B.    To quickly plot a function y(x) vs. x  you can type y@x, which will plot over a default range.

Example: myfcn z( ) z2 sin z( )⋅:=

10 5 0 5 10
100

50

0

50

100

myfcn z( )

z

Produced by typing
myfcn(z)@z and 
then hitting return.
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C.  You can also do fancier plots:  Use the mouse to change perspective for this 3D plot:

j 1 50..:=

k 1 50..:= Mj k,

1 104⋅ sin
j

5






⋅

k 10+( )2
:=

M
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